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Introduction
Thank you for using ATMOS, a comprehensive weather reporting solution for broadcast radio
and television stations; air traffic control facilities; and mass-transit systems. We hope that you
enjoy using the product and find it easy to operate. This manual is updated often to reflect the
feature set present in the most recent version of the software. For information on upgrading,
please see the section titled ‘Upgrading to the Latest Version’.

Background of Summit Technology Group

Summit Technology Group is a Keego Harbor, Michigan based broadcast software manufacturer
and broadcast engineering firm that operates throughout the globe. Some of our other products
include SideCAR Media Logger, TundraCast Audio Streaming, and TowerLytics Tower Light and
Site Monitoring. Our services span studio and transmitter site design/build, tower climbing, RF
and transmitter maintenance, regulatory filings, and automation consulting. For more
information about our other products or our broadcast engineering services, please visit us
online at www.summittechgroup.com or call our sales team at (248) 706-6963 Option 1. The
hyperlinks in this section are a convenient way to navigate directly to the associated pages on
our website.

Theory of Operation
ATMOS serves the need for completely automated routine and emergency weather reports. To
achieve this, many of ATMOS’ functions are automated and are capable of running without
human intervention. The workflow depends on a user to initially setup and configure the
program to work in an automated manner. The most common configuration settings are
described in this manual.

For information on how to ingest ATMOS audio files with a specific brand of automation
software, please refer to ‘Appendix A’.

General Settings
The ‘General Settings’ menu contains all the global and general settings for the instance of
ATMOS.

Save - Saves the current settings globally for the entire program (not just the settings controlled
with the ‘General Settings’ menu.
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Reset - The ‘Reset’ button completely resets the ATMOS settings file back to default values.
This includes settings present in all menus and managers (except those dependent upon
databases). Only use this button if your settings file has become corrupted or at the direction of
Summit Technology Group support technicians.

File Settings

File Path - The file path for the
final report audio. This path may
be manually inserted or the user
can browser for the file path with
the adjacent ‘Browse…’ button.

File Name - The filename for the final report audio. The filename can be static or dynamic. For
example, with certain automation systems, you may need to keep the name of the file consistent
such as 13724.wav. Other systems may accept certain data which can be inserted dynamically
using the wildcards below. One possible use for these wildcards is persisting temperature and
weather condition data through to RDS or other PAD endpoint.

File Name Wildcards:

@MM Produces 2 digit Month. Example: 07

@DD Produces 2 digit Day. Example: 04

@YY Produces 2 digit Year. Example: 21

@HH Produces 2 digit Hour. Example: 17

@mm Produces 2 digit Minute. Example: 30

@ss Produces 2 digit Second. Example: 14

[temp] Produces an integer of the current temperature in the primary community.
Example: 75

[wx] Produces a string value of the current conditions in the primary community.
Example: Cloudy

[advertID] Passes the AdvertID of the sponsor used in the report (if applicable) for use
when monitoring for impressions. Example: 97624

[rand] Produces a pseudo-random integer. Length is only configurable using the
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settings file directly. Example: 64283265

[ext] Passes the correct extension for the file (Wav). Example: wav

General Settings

Start on Windows Login - This setting utilizes the Windows registry to automatically start upon
Windows login.

Minimize to Tray - This setting hides the Taskbar icon when ATMOS is minimized and instead
shows the ATMOS icon in the Windows Tray. This helps prevent ATMOS from being closed
inadvertently by a user and helps minimize the number of icons on the Taskbar.

Enable Debug Logging - Add verbose debugging statements to the log by setting this to true.
This is mainly used by Summit Technology Group support technicians to identify and
troubleshoot issues.

Normalize Audio - Set this to true to normalize the report audio in its final stage. Audio
normalization is the application of a constant amount of gain to an audio recording to bring the
amplitude to a target level. Because the same amount of gain is applied across the entire
recording, the signal-to-noise ratio and relative dynamics are unchanged.

Two principal types of audio normalization exist. Peak normalization adjusts the recording based
on the highest signal level present in the recording. Loudness normalization adjusts the
recording based on perceived loudness.

AdvertID UDP Port - User defined port for incoming UDP strings from automation or PAD
middleware used to increment the number of times a particular sponsor message has aired. For
information on configuring this setting,
see the section titled ‘Sponsor
Monitoring and Reconciliation’.

Country - The country in which this
instance of ATMOS is being used.

Set Waveform Color - These two
settings define the color of the
background and foreground for the
waveform used for emergency alerts.
This is simply a color preference for the
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operator and does not affect the behavior of ATMOS.

Script Selection Method

Pseudo-Random - A script template selection method that pseudo-randomly selects an ATMOS
Script Template (.ast filename extension) from the available templates.

Programmatic - A script template selection method that selects an ATMOS Programmatic Script
Template (.apst filename extension) based upon the Current Conditions in the Primary Location.
Additional mappings for all weather conditions are made in the ATMOS configuration file.

Interval Settings

The interval settings allow the user
to enable or disable the automated
(timer-based) delivery. It also
allows the user to specify the
interval length. The interval can be
set to any number of minutes (minimum of 5 minutes). Automated delivery is recommended only
if the user is not intending on using automation control to trigger new alerts (such as for time
announcements). This setting can be remotely enabled and disabled using the commands
described in the section titled ‘Automation Control’.

EAS Unit Connection

This setting is used to set the connection to an EAS Encoder for purposes of issuing a Required
Weekly Test (RWT) from ATMOS (or through the use of a UDP command issued from an
automation system).

The first step in configuring this
connection is to specify the IP address of
the EAS encoder. The IP Address shall
be entered simply as nnn.nnn.nnn.nnn
without any trailing characters for
specifying the port. Next, specify the
model of compatible EAS encoder with
the ‘EAS Model’ dropdown. Finally, use
the ‘Ping EAS Unit’ button to test the

connection to the EAS encoder. Most models of EAS units will return some acknowledgement in
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the ‘Reply’ field. For more information on setting up the proper settings within your EAS device,
refer to the ATMOS section of the knowledge base for a whitepaper that describes the process.

Finally, to test sending an RWT, click the ‘Send RWT’ button in the EAS Unit Connection
settings. Information on issuing commands from automation to send an RWT can be found in
the section titled 'Automation Control'. Furthermore, manual commands can be sent using the
‘EAS Alerting’ menu from the main ATMOS window.

Regulatory Compliance Note:
§11.61(a) stipulates that ‘Analog and digital AM, FM, and TV broadcast stations must conduct
tests of the EAS header and EOM codes at least once a week at random days and times. The
‘random’ nature of such tests can be accomplished by allowing operators to issue commands
in an ad-hoc fashion. RWTs shall not, for example, be scheduled on a recurring weekly basis
on Tuesdays at 3:30 AM.

Personalization Settings

Script Settings

Replace AM/PM with Morning/Afternoon - Enable this setting to replace instances of ‘AM’ and
‘PM’ with ‘Morning’ and ‘Afternoon’ such as in ‘PM Snow Shower’. This setting will also correct
articles ‘a’ and ‘an’. For example, in the case where the forecast calls for ‘a chance of a PM
shower’ ATMOS will speak ‘a chance of an afternoon shower’.

Daily temp range should conform to current temp - Enable this setting to artificially raise the
current day’s high temperature or lower the current day’s low temperature based upon the
current temperature. For example, enabling this setting will eliminate any instances where
ATMOS would return a script that said, ‘Today’s high will be 74 degrees. Currently 76
downtown’.

Generalize Future Temps - For certain instances where a single location is used, a word (or
string of words) can be used to replace the second temperature in an array of 2 or more
temperatures. For example, if today and tomorrow will both be 59°, the script may read
‘Tuesday’s high will be 59 and the same on Wednesday’.

Call Sign Enumeration - For stations
with call letters that resemble a word
in the report language that chose to
use said call letters in their script
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templates, Call Sign Enumeration can be used. This setting if enabled and call letters specified
will ensure each letter is spoken independently of the others. For example, WORK or WHAM
would be pronounced as call letters as opposed to the words ‘work’ and ‘wham’.

Temperature Generalization

Temperature Generalization controls how the generalized temperatures are read. More
information about the GenTemp[] AML tag can be found in the section titled ‘Modifier Type AML
Tags’. The two possible options are ‘Upper/Mid/Lower’ and ‘High/Mid/Low’.

Background Music Settings

Master Voice Settings

Voice Source - This setting allows the user to specify between the use of a cloud-based
synthesized voice and a local-based SAPI-5 synthesized voice.

Reporter Voice - The specified voice of the weather report voice when using a cloud-based
synthesized voice.

Sponsorship Voice - The specified voice of the national spot voice when using a cloud-based
synthesized voice. This setting is currently only for barter tier clients that take traffic from
Summit Technology Group.

Alternate Character - This setting alternates the character(s) after each report so as to mix up
the voices from report to report. This only applies to instances where the voices selected are
different.

Male Reporter Name - The name that is used to replace the ‘[CharacterName]’ AML tag when
the ‘Reporter Voice’ selected is a male or masculine voice.

Female Reporter Name - The name that is used to replace the ‘[CharacterName]’ AML tag when
the ‘Reporter Voice’ selected is a female or feminine voice.

Local Voice Settings

Voice Name - This dropdown enumerates all the available SAPI-5 voices installed on the
computer and allows the user to set the desired voice to use if ‘Voice Source’ is set to ‘Local
Voice’.
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Speaking Rate - A user defined rate of speech that ranges from -10 to +10. The default (normal
speaking rate) is 0.

Name Settings

Nationality of Name - Used for the ‘Random Name API’ to generate a name of particular origin.

Script Editor
The script editor allows the user to create, load, and edit ATMOS Script Templates, ATMOS
Programmatic Script Templates, and ATMOS Emergency Script Templates all from an integrated
helpful editor.

To create a new ATMOS Script Template, simply select File>New. Set the name of the script
template in the ‘Standard Script Name’. Finally, use the script text box to write the script.

To edit an existing script, simply select File>Open… and select the file you wish to edit.

To create a new ATMOS Programmatic Script Template, simply select ‘New Programmatic
Script’. Ensure the box is checked to ‘make the script programmatic’. Select the desired
Weather Condition from the dropdown. This will load the current script if one is already
available. Finally, use the script text box to write or edit the script.

In all cases, to save the edited script, simply select File>Save or use the keyboard shortcut
Ctrl+S.

Printing a script template can be done by selecting File>Print.

The ‘Insert’ menu has many of the most common ATMOS Markup Language (AML) Tags that,
when selected, will be inserted into the script template at the current cursor position. The next
section details all the AML Tags that exist as well as an explanation of how to use each tag.

ATMOS Markup Language (AML) Tags
ATMOS Markup Language (AML) Tags are divided into two main groups and further subdivided
by the number of ‘dimensions’ they can have. The two main groups are ‘Data’ and ‘Modifiers’.
Data types are replaced by dynamic data at runtime whereas Modifiers modify Data or other
strings.
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Most commonly, data will have 1 or 2 dimensions (often location and time). Thus, many AML
Tags will have arguments such as {p, 0}. In most cases, Location comes first and Time (such as
day) follows. Location arguments can be any index of a location in the Locations Manager, ‘p’
for the Primary Community, or ‘r’ for a globally random location index each time a report is run.

For example, the Location AML Tag can be written as [Location{2}], [Location{p}], or
[Location{r}]. All will produce a specific result. In the below table, we will typically use {p}.

Data Type AML Tags:

AML Tag Explanation of Use

[Location{p}] The name (or phonetics if present) for the given location {p}.

[ForecastHeadline{p, 0}] A variable length forecast headline for the given location and
period.

[ForecastName{p, 0}] The name of a particular period for the associated
ForecastHeadline. For example, 0 might indicate Today, 1
indicates Tonight, 2 indicates Tomorrow and 3 indicates
Tomorrow Night. The location is needed because some NWS
weather offices do not abide by this standard.

[CurrentTemp{p}] Integer value of the current temperature for the given location.

[HiTemp{p, 0, i}] Integer value of the expected high temperature for the given
location on the specified day (index 0-4). The final argument is
optional and indicates a specified unit of measure (i = imperial,
m = metric).

[LoTemp{p, 0, i}] Integer value of the expected low temperature for the given
location on the specified day (index 0-4). The final argument is
optional and indicates a specified unit of measure (i = imperial,
m = metric).

[TempUnit] The unit of measure used for the temperature given country
settings.

[CurrentWindSpeed{p, i}] Integer value representing the current wind speed in a given
location in a specified unit of measure (i = imperial, m = metric).

[FutureWindSpeed{p, 1, i}] Integer value representing the forecast wind speed in a given
location for a specified day in a specified unit of measure (i =
imperial, m = metric).
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[CurrentWindDirection{p}] Directional value of the wind in the specified location at the
present time. Example sentence: ‘Winds are out of the
[CurrentWindDirection{p}]’. Returns one of the 8 cardinal or
intercardinal wind directions.

[FutureWindDirection{p, 1}] Directional value of the wind in the specified location and the
specified day. Example sentence: ‘And on [Day{2}], winds will
be out of the [CurrentWindDirection{p, 2}]’. Returns one of the
8 cardinal or intercardinal wind directions.

[Day{0}] The name of the day of the week for the specified day (index
0-4). Returns a string value such as: ‘Tuesday’. Can be
modified to be made plural such as ‘[Day{1}]’s high will be’.

[FormalDate] Returns a string such as ‘Tuesday, December 8th’ for the
current date. Does not include the year (see [Year]).

[SlangDate] Returns a string such as ‘Tuesday, the 8th day of December’
for the current date. Does not include the year (see [Year]).

[Year] Returns the current year. For example, ‘2019’.

[Daypart{0}] Returns the desired Daypart (morning, afternoon, evening)
based on the optional argument acting as an increment or
index from the current daypart.

[FormalTime{00:05, true}] Returns a time such as ‘5:35 PM’. Can be incremented by a
positive number of hours and minutes (first argument) and can
include the time period (AM/PM) based upon the boolean
argument.

[SlangTime{00:05}] Returns a time such as ‘20 minutes to 2’. Can be incremented
by a positive number of hours and minutes.

[CurrentWx{p}] Returns the current conditions in the given location. Example:
‘Cloudy’ or ‘Snow Showers’.

[Conditions{p, 1}] Returns the forecast conditions in the given location for the
given day. Example: ‘Cloudy’ or ‘Snow Showers’.

[ObservationTime] Returns the time the latest weather observations were made.

[CharacterName] Returns the string value of the character name whose gender
matches that of the report.

[Holiday] If an enabled holiday falls on the day the report is being
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generated, the greeting set for that holiday will be returned.
Otherwise, the NoHoliday greeting will be returned. For more
information, refer to the section titled ‘Holiday Manager’.

[Sponsor] Pseudo-randomly returns an active (not expired) and eligible
(considering day of week and daypart) sponsor message from
the sponsor manager. Requires certain paid plans or add-on
packages. Not available to barter tier users. For more
information, refer to the section titled ‘Sponsors Manager’.

Modifier Type AML Tags:

AML Tag Explanation of Use

GenTemp[] Generalizes to the tens place any integer it wraps (typically used
for temperature). For example, considering an expected high
temperature of 68 in 2 days, ‘GenTemp[HiTemp{p, 2, i}]’ would
return ‘Upper 60’s’ or ‘High 60’s’. This tag supports nesting (AML
tags within AML Tags).

Example sentence:
[Day{2}]’s high is expected to be in the GenTemp[HiTemp{p, 2, i}].

RandPhrase() Pseudo-randomly returns 1 of n arguments, delimited by vertical
bars ‘|’ and wrapped in standard parentheses ‘(‘ and ‘)’. This tag
supports nesting (AML tags within AML Tags).

For example:
RandPhrase(I’m [CharacterName], have a great day|Enjoy the
rest of your [Day{0}]|Keep listening and have a great [Daypart])

[TempTrend{x, y}] Returns a user-defined phrase to describe the trend in
temperatures ‘x’ and ‘y’. Phrases are based on user defined
magnitudes and the increase or decrease of temperature. The
variables ‘x’ and ‘y’ are typically AML tags such as ‘[HiTemp{p, 2,
i}]’ or [LoTemp{p, 3, i}].

For example:
[TempTrend{[HiTemp{p, 0, i}], [HiTemp{p, 1, i}]}]

Warmest()

[Coming Soon]

Returns an integer value; the warmest temperature in the data set
delimited by commas.

For example:
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Warmest([HiTemp{p, 1, i}], [HiTemp{p, 2, i}], [HiTemp{p, 3, i}])

Coldest()

[Coming Soon]

Returns an integer value; the coldest temperature in the data set
delimited by commas.

For example:
Coldest([LoTemp{p, 1, i}], [LoTemp{p, 2, i}], [LoTemp{p, 3, i}])

Average()

[Coming Soon]

Returns an integer value; the average temperature in the data set
delimited by commas.

For example:
Average([HiTemp{p, 1, i}], [HiTemp{p, 2, i}], [HiTemp{p, 3, i}])
Or
Average([HiTemp{p, 1, i}], [LoTemp{p, 1, i}])

Modifier AML Tags in Depth

GenTemp [ ]
GenTemp[int] is able to generalize temperatures by speaking them as low, mid, or upper values.
For example, the temperature 57 degrees would be read as 'upper 50's'.

The proper syntax for this tag is as follows:

GenTemp[HiTemp{p, 1, i}]

NOTE: This tag partially supports nesting (the inclusion of wildcards or AML tags within
itself, limited here by the data type)

With additional context, this would produce: Tomorrow, expect temperatures in the 'upper 50's'.

RandPhrase ()

RandPhrase() is able to pseudo-randomly select one of a collection of possible phrases that
would logically be placed at a given spot in a script. For example, it could pseudo-randomly
decide on what forecast data to read or how to read the end of the report.

The proper syntax for this tag is as follows:

14 Rev. 021622



RandPhrase(<option1>|<option2>|<option3>|<optionN>)

NOTE: This tag fully supports nesting (the inclusion of wildcards or AML tags within
itself)

A real life example would be:

RandPhrase(Today's high will be [HiTemp{p, 0}]|Expect
temperatures as high as [HiTemp{p, 0, i}]|[HiTemp{p, 0, i}] is
today's high)

OR

RandPhrase(Enjoy your [Daypart]|Have a great [Daypart]|Have a
wonderful [Daypart]|Thank you for listening to WHAM The Pig)

[TempTrend{x, y}]
TempTrend returns a user-defined phrase to describe the trend in temperatures ‘x’ and ‘y’.
Phrases are based on user defined magnitudes and the increase or decrease of temperature
and are set in the ‘Temperature Trends’ menu. The variables ‘x’ and ‘y’ are typically AML tags
such as ‘[HiTemp{p, 2, i}]’ or [LoTemp{p, 3, i}]. For more information, refer to the section titled
Temperature Trends’ under the ‘ATMOS Settings Managers’ section.

ATMOS Settings Managers
ATMOS utilizes a variety of tools called managers. Managers offer greater flexibility to the user
than do menus when there are infinite configuration possibilities. To ensure reliability and data
integrity, ATMOS managers each use their own database(s). The location of the database shall
be the root of the application run directory.

For information about database design, our API, or custom development services to integrate
ATMOS into other workflows, please contact Summit Technology Group at the contact
information listed at the end of this manual.

Holiday Manager

The ATMOS Holiday Manager allows the user to specify which holidays they wish to announce
using the ‘Holiday’ AML Tag. The manager lists 10 US Federal Holidays that are predictable
based upon a calendar along with ‘NoHoliday’. Each of these have an associated greeting. The
greetings are accessible by right clicking on the holiday and selecting ‘Edit Holiday Greeting’
from the context menu.
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Upon doing this, the greeting will appear in the ‘Holiday Greeting’ group box and be ready for
the user to edit and save when finished. The holiday greetings can be nested, meaning they can
contain other AML Tags within
them.
NoHoliday will always remain
selected as it is not possible to
disable that ‘holiday’.

At runtime, if the day in which a
report is run is not a holiday, the
‘Holiday’ AML Tag will return the
greeting associated with ‘NoHoliday’, otherwise it will return the greeting associated with the
holiday that falls on that day. Pictured above is an example of a report that ran on 12/25
(Christmas Day).

Locations Manager

The ATMOS Locations Manager is where the station’s primary and secondary communities are
set up. These locations serve as the basis for the weather reports by providing ATMOS with
‘Location Name’ and ‘ZIP Code’. Setting up locations in the Location Manager can provide your
forecasts with more specificity and even show smaller outlying communities that you care about
providing them with the weather. Standard plans include between 3 and 5 licensed locations.
More locations can be added with add-on packages to your subscription. To update your
subscription, login to your client portal or contact Summit Technology Group for assistance.

One example is to cite a metropolitan area such as Detroit. An ATMOS report can make use of
the ‘Location’ AML Tags as well as the associated ‘CurrentTemp’ and ‘CurrentWx’ tags to create
a report that results in the following:
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“68 degrees in Detroit currently under cloudy skies, 64 in Pontiac, and good morning to listeners
in Royal Oak, 66 degree temps for you.”

Adding a Location
To add a location to the Location Manager, start by entering the ZIP Code into the ‘ZIP Code’
field and search for the associated location. The ‘Location Name’ will be populated with the
official name of the desired location.

Legacy versions of ATMOS also rely on ‘LocID’. This LocID is a uniform address for a specific
location used by ATMOS to pull the proper weather data.

Should a Location Name be mispronounced by the synthesized voice, the phonetics can be
input in the ‘Phonetics or Nickname’ field. In addition, if a location should be addressed by a
nickname, it can be input here as well. Examples include ‘The Twin Cities’, ‘The Township’, or
‘The Motor City’. If the ‘Phonetics or Nickname’ field is empty, the ‘Location Name’ will be used
to replace the ‘Location’ AML Tag when generating reports. Note that the text of the report will
always use the ‘Location Name’ and the ‘Phonetics’ will only be used for the synthesized
speech.

‘Primary Community’ denotes the community is the main location. This can be referenced in a
script template with any AML Tags that support the ‘{p}’ argument. This also sets the current
conditions and temperature in the filename of the file for persisting data through to an RDS or
other PAD endpoints. There is a limit of 1 primary community in the database.

Updating a Location
To update a location in the Location Manager, simply double click the
row of the location you wish to edit. This will populate the ‘Location
Data’ and allow you to make the necessary changes. To change the
‘Location Name’, you may need to click the search button to reinitialize
the search results as these are not cached or stored in the database.

Removing a Location
To remove a location from the Location Manager, simply click the row
header to the left of the location you wish to remove and press the ‘Delete’ key. You will be
prompted with a message box confirming deletion. This action cannot be undone.
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Sponsor Manager

The ATMOS Sponsor Manager allows users on select paid plans to monetize their weather
report. In doing so, a station would sell weather sponsorships and include the sponsor’s
message in the database. Each message can be set to play only during specific days of the
week or dayparts. An expiration date can be used to expire a sponsor message. The ‘Sponsor’
AML Tag will be replaced at random with an eligible message each time a report is run.

After adding, updating, or deleting a sponsor message, select File>Save Changes to commit the
changes to the database.

The File menu also allows the user to access the print dialog and various export functionalities
to use the data for traffic and billing purposes.

The ‘Default Sponsor Message’ is used in place of any specific sponsor message if not eligible
messages are active at the time of the report running. This default message may be left blank or
serve as a sort of promotional message to encourage other advertisers to sponsor the weather
on your station. To edit the ‘Default Sponsor Message’, simply click Tools>Default Sponsor
Message. Make the desired changes to the message and click ‘Save’.

The ‘Reports’ field in the database keeps track of the number of reports the sponsor message is
included in whereas the ‘Impressions’ field reflects the number of times your automation system
played the sponsor message as a part of the report. An explanation of how to set this up can be
found in the section titled ‘Sponsor Monitoring and Reconciliation’.

Adding a Sponsor Message
To add a sponsor message, simply click File>New Sponsor Message or use the shortcut keys
Ctrl+N. Next specify the name of the sponsor and the sponsor message in the text boxes
provided.

The sponsor message may be similar to, “This ATMOS Weather Report is being brought to you
by Bill Wheeler Automotive, for the best cars at the lowest price, call Bill Wheeler today at 1
(844) WHEELER…”

To activate the message immediately, ensure the ‘Active’ checkbox is checked. If you wish to
activate the message at a later time, the check box can be unchecked. The ‘Active’ checkbox is
checked by default.
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The ‘Scheduling Options’ group box allows the user to specify which days of the week and day
parts the sponsor message may air. The ‘Expiration’ allows the user to expire the message at a
certain date. This is helpful for dealing with fixed time flights or where the message promotes an
event or time-sensitive promotion.

Below is a chart of the various dayparts and the times of day they correspond to:

Daypart Times of Day (24-Hour Format)

Morning Drive 06:00 - 10:00

Mid-Day 10:00 - 15:00

Afternoon Drive 15:00 - 19:00

Evening 19:00 - 00:00

Overnight 00:00 - 06:00

Updating a Sponsor Message
To update a sponsor message in the Sponsor Manager, simply click the row header to the left of
the location you wish to edit. Then click File>Update Sponsor Message or use the shortcut keys
Ctrl+U. Follow the same procedures as adding the sponsor message and click ‘Update’.

Removing a Sponsor Message
To remove a sponsor message from the Sponsor Manager, simply click the row header to the
left of the location you wish to edit. Then click File>Delete Sponsor Message or use the shortcut
key Del. You will be prompted with a message box confirming deletion. This action cannot be
undone.

Sponsor Monitoring and Reconciliation
ATMOS has the ability to monitor metadata coming from your automation system to determine
how many times a particular sponsor message plays. For example, if a station schedules a
report to play 6 times an hour, the sponsor in that report would get 6 impressions (one
impression for each time it aired). If, on the other hand, the report gets updated and pulls a
sponsor message but the report is not played at all that hour, the sponsor message would
accrue 0 impressions.

Setting up the sponsor monitoring and reconciliation feature varies between automation
systems but below is a general guide on how the configuration should be done.
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Include ‘[advertID]’ in the Filename
Add the ‘[advertID]’ AML Tag to the
filename in General Settings. At the
time a report is generated, the
‘[advertID]’ AML Tag will be replaced with the 5 digit numerical AdvertiserID in the Sponsor
Manager. Nothing will prepend or append this 5 digit number.

Configure your Ingest Middleware
The next step is to configure the ingest middleware used to ingest ATMOS audio files into
automation for playout. In most cases, ingest middleware will allow the user to configure what is
referred to as a filename parse. This technique allows the middleware to capture metadata for
the audio file based on the filename and the data separated by delimiters. The underscore (‘_’)
is a common delimiter used for this purpose.

While it is up to the user to decide which library field will ultimately store the ‘advertID’, we
recommend it be a field that is seldom used and will not cause issues with other traffic,
newsroom, or playout functionality. The middleware should be configured to overwrite the value
each time a new file is ingested as the file will likely have a different ‘advertID’ than the report
before it.

Configure your PAD Output
The next step is to ensure the ‘advertID’ metadata stored in the library database is sent back to
ATMOS on the UDP port specified in General Settings. The playout software shall be configured
to send a string via UDP to the instance of ATMOS that resembles the following:

advertID=42839

In the automation system configuration, there will likely be a tag that corresponds to a field in
the library such as [TITLE] and [ARTIST]. Use the tag that corresponds to the field responsible
for storing the ‘advertID’. The string ‘advertID=’ shall be literal text prepended to the ‘advertID’.

The string may contain other characters but should at a minimum contain the above string. This
will be interpreted by ATMOS and added to the Sponsor Manager database.

Changing the UDP Port
To specify a different UDP port on which to monitor for incoming PAD data, see the section titled
'General Settings'. A restart of ATMOS is required after making this change.
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Background Music Manager

The Background Music Manager provides access to the ATMOS Background Music
Marketplace, a free online marketplace of beds for your weather reports. The Background Music
Manager allows the user to browse through the various royalty-free beds available for use and
add them to the user’s library. Each time a report is run, a bed will be pseudo-randomly selected
from the user’s library for use in the report.

Select background music from a variety of ‘Formats’ listed on the left hand pane of the
Background Music Manager. Upon clicking into a particular format, the ‘Available Beds’ will
populate the upper list box. Selecting a bed and clicking ‘Add’ will add that bed to the user’s
library and be available for use in the next report. To remove a bed from the library, simply click
the bed from the lower list box and click ‘Remove’. In each case, clicking ‘Save’ will save any
changes.

Importing a Custom Background Music Bed
To import a custom background music bed, simply launch the ‘Background Music Manager’ from
the ‘Main Menu’ and then click Music Menu>Music Importer. This will bring up the Background
Audio Importer tool. From here, simply use the ‘Browse…’ button and select a wav audio file.
Set the ‘Name’ and ‘Artist’ of the audio file and click ‘Import’. Once the file is imported, you can
close the Background Audio Importer tool.

Temperature Trends

The Temperature Trends menu
allows users to set the phrases for
various temperature trend
situations. Temperatures can be
described by two characteristics,
magnitude and direction. ATMOS
allows a user to set the parameters
that define the magnitudes (same,
mildly, standard, and greatly).
Direction can either be warming or
cooling. The phrases set in this
manager can contain nested AML tags. For example, if the [TempTrend{x, y}] tag is used and
the first value is 58 and the second value is 42, the trend would be said to be ‘cooling greatly’.
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The returned phrase could be something like: ‘with temperatures dropping significantly to
[HiTemp{p, 1, i}]’.

Automation Control
ATMOS can be controlled over a Local Area Network (LAN) by passing UDP strings from an
automation or playout system to ATMOS on the automation control port. These are often used
to control ATMOS functions and behavior as well as trigger new reports at certain times of the
day. The control port is, by default, set to UDP 5009. Below are the various UDP commands that
you can use to trigger functions in ATMOS:

Command Explanation

GENERATE REPORT Used to generate a new report.

EAS RWT Used to issue an RWT to a connected EAS Encoder.

EAS PING Used to ping a connected EAS Encoder.

EAS POLL Used poll a connected EAS Encoder.

ENABLE AUTOMATED Used to enable automated delivery of weather reports.

DISABLE AUTOMATED Used to disable automated delivery of weather reports.

DOWNLOAD SPONSORS Used to download new sponsors on demand (barter tier).

PLAY REPORT Used to play the EAS alert or enabled routine report.

STOP REPORT Used to stop the EAS alert or enabled routine report.

UNLOAD REPORT Used to unload the EAS alert or enabled routine report.

TOGGLE SCRIPTING METHOD Used to toggle between scripting methods.

EXIT Used to exit ATMOS without prompting for confirmation.

Licensing and Support
ATMOS is licensed on a hybrid cloud and local model meaning the license data (number of daily
reports, remaining reports, and various keyed features) are stored in the cloud. To sign up for
ATMOS and obtain a login credential, simply sign up online at
https://www.summittechgroup.com/atmos-plans#Subscription-Plans or contact Summit
Technology Group sales.
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Once a user has signed
up for an ATMOS account,
they will receive an email
with a link to the latest
installer, the email address
they used to register for
the account and the
subscription ID (starts with
‘SUB-’). After installing
ATMOS, the licensing process is very
simple. Launch ATMOS and click
‘Login’ in the upper right hand corner
of the main window. Then click the link
for ‘First time logging in?’. The
password reset window will appear
and ask for your email address and
subscription ID. After clicking ‘Verify
License’, ATMOS will verify the information you supplied in those two fields. If the subscription is
valid and the password has not yet been set, ATMOS will prompt you to set and confirm a new
password. We recommend using something that everyone in your organization would know as
opposed to a personal password. After the password has been set, ATMOS will prompt you to
return to the login window and use the email address and newly set password to login.

Once logged in, you will be able to view details about your license as well as set whether or not
ATMOS should auto login to the account on application restart. This is highly recommended for
automated setups where a user would not be present to login. Details about your license include
if you are licensed for multi language support, sponsorship manager support, IPAWS integration
support, EAS RWT integration support, number of licensed locations, number of reports per day,
and your account ID (call sign).

For convenience, the last line of the license details includes a statement as to whether or not
ATMOS is licensed to the current device.

Password resets can only be initiated by Summit Technology Group support. To have your
password reset, please send an email indicating such to licensing@summittechgroup.com from
the email address on file and include your subscription ID.
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Upgrading to the Latest Version
From time to time, it may be necessary to upgrade to the latest version of ATMOS. All licensed
users (those with an active paid subscription or an active barter agreement on file) are entitled
to free upgrades of ATMOS. To update to the latest version, simply click Help>Upgrade to Latest
Version. After prompting the user to proceed, ATMOS will download the latest installer and run
the installer silently in the background. ATMOS will restart when the installer is complete.

ATMOS About Window
The ATMOS About window presents information about what version of ATMOS is running as
well as provides legal information about the various trademarks, copyrights, libraries,
components, APIs, and fonts used in ATMOS. When communicating with Summit Technology
Group technical support, the version number is important to know.

ATMOS User Forums
Users seeking to learn more about their ATMOS system are encouraged to join and participate
in discussions on the ATMOS Product Forum (available from our website:
www.summittechgroup.com). The forum is the ideal venue for collaborating on script ideas and
AML Tag usage, submitting feature requests, or requesting general assistance that may be
helpful to others. The forum is not an ideal venue for licensing, pricing, or specific technical
support inquiries. For specific technical support or assistance as it relates to your license,
please see the section titled 'Seeking Technical Support'.

Seeking Technical Support
For technical support questions or assistance, please contact Summit Technology Group
technical support by submitting a ticket via our website (www.summittechgroup.com/support) or
email support@summittechgroup.com. Users with a Gold Plan, Commercial Barter Plan, or a
Technical Support add-on may call us at (248) 706-6963 and select option 2 for product support.

Managing My Subscription
To manage your ATMOS subscription, simply navigate to the ‘Client Portal’ on our website
(www.summittechgroup.com) and select ‘Online Payment Portal’. Here you will be able to make
changes to a subscription, view, approve, and pay quotes and invoices, and even track
engineering projects (if applicable to your account). Credit card and bank account details can be
securely edited from this portal.
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Concluding Thoughts
It is with great pride and pleasure our development and support teams work to provide you with
a comprehensive solution to automated weather reporting. We look forward to building a lasting
relationship with you, your station, and your team and look forward to assisting any future
broadcast challenges. We further hope that you pass along our name to colleagues and
evangelize our product if you feel it deserves praise. Finally, if any portion of this product can be
made better, we encourage you to let us know. The forum is typically the best venue for these
types of feature requests but we are always open to hearing from you directly.

Thank you,
Paul Stewart
President, Summit Technology Group
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Appendix A: Configuring ATMOS for Various Automation Systems

Station Playlist

The following aims to provide the steps needed to configure ATMOS to Station Playlist
automation software.

Open StationPlaylist Creator, and
left-click within the window.

Create ‘New’ category
‘Weather’, with path of
C:\ATMOS\

Save Changes
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Configure ATMOS to output to
‘C:\ATMOS\WEATHER.wav’.

Schedule/play “WEATHER.wav" as
you would any other audio element
in StationPlaylist Creator/Studio.
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ENCO DAD
The following aims to provide the steps needed to configure ATMOS to the ENCO DAD
automation software.
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Appendix B: Script Editing In Depth

Opening Script Editor

Top left corner of the ATMOS panel is the Main
Menu option. This menu has the option Script
Editor.

After opening this panel, click
FILE, OPEN, click the default
script for now. More scripts can
be added later.

At the top of the editor, use Insert to add customizations
such as Current Temperature, High Temperature, Character
Name, etc.

Programmatic Scripts:
Programmatic scripts are scripts that will be selected based on the current weather conditions.
Programmatic script files end in .apst (ATMOS Programmatic Script Template).
For example, if the weather report specifies the current conditions in the primary community is
Cloudy, then the cloudy script will be used to create the report. Examples are shown below.

29 Rev. 021622



To see Programmatic
Scripts, check the box
that is highlighted on
the image to the left.

Here is the cloudy
script in the script
editor.

The ‘cloudy’ script being
played in the current report.

Setting up Programmatic Scripts:

The highlighted portion shows the ‘Script Selection Method’, which has to have ‘Programmatic’
selected for programmatic operation. Then click SAVE.

To EDIT or CREATE a programmatic script:

In the script editor, select ‘make this script
programmatic’.

30 Rev. 021622



You can then create a new script, or open one that is already available and customize it. For
example:

Pictured are the options of Programmatic
Scripts and possible weather conditions that
ATMOS will report.

Here is the SUNNY script open
in Script Editor:
You can customize this script by
using the INSERT tab at the top
of the screen.

NOTE: when the report is
SUNNY, this script will become
the current report.

Adding New APST Scripts:

The next steps go over how to create a new APST file and how to correctly map the file to the
correct condition it falls under.

First Step: Creating the new APST File

In the script editor, select the
box highlighted, then select
‘New Programmatic Script’.
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NOTE: To find where your scripts are later, follow this path.
C:/ProgramData/Summit Technology Group/ATMOS/Scripts

After you have selected ‘New Programmatic
Script’, create the name of the script and
click ‘OK’.

NOTE: The file should always have an underscore between each word (if multiple words)

To open your new script. Select the dropdown
menu, and find the new script name. In this
example, ‘Weather_Conditions’ is the new script.

Select it, then begin typing in the box below. Here
is where you will create the script.

Second Step: Mapping the APST File

On the ATMOS icon on the desktop, right click, and select
Open File Location

OR

By following this path, you can get to the same location. C:/ProgramData/Summit
Technology Group/ATMOS
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Open this file with Notepad AutoWeatherAnnouncer.exe.config

NOTE: if this file does not appear,
please refer to Viewing Hidden
Files whitepaper.

In Notepad, look for
<AutoWeatherAnnouncer.Properties.Conditions>

This file is where all the weather conditions are listed and mapped.

In the example the the left, here is how
this would work:

When the weather conditions are any of
the following,

- “Sunny”
- “Mostly sunny”
- “Partly sunny:”
- “Intermittent clouds”
- “Hazy sunshine”

The Sunny APST file is then used as
the current weather report.
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Now knowing that, let's map your new APST script.

Here is an example of one that you might create:

Let's say the new APST file is called Heavy_Rain.apst
This new file is going to have to be mapped to the RAIN condition.

The Notepad file would look like this before the change,

And would end up looking like this because of the new APST file title.
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